OpenSSL Security Upgrade

Big Mountain is pleased to announce that most recent OpenSSL upgrade has been applied to all of our servers and firewalls. This upgrade fixes a security vulnerability in OpenSSL 1.01, otherwise known as the “Heartbleed” bug, which allows an attacker to read arbitrary data from the process memory and steal private keys of SSL certificates.

Full details of the vulnerability, including more technical details, can be found at: http://heartbleed.com/

It is recommended that you change your passwords as a precaution. Please contact us 866-910-1070 if you have any questions regarding this upgrade. Thank you.